Exploiting this FileAPI flaw requires a user to visit a malicious web page, and a successful attack runs code inside Chrome's sandbox rather than on the underlying system. An attacker could still gain full code execution on the host by chaining it with a sandbox escape such as CVE-2026-118306, or by targeting an automated browser running with the sandbox disabled. No exploitation has been reported; update Chrome to 156.0.8078.73 or later, along with other Chromium-based browsers and Electron apps.
Vulnerability intelligence
Updated an hour ago
FeedsTrending now
CVEs trending on social media within the last 24 hours
Hypemeter
Current score
Wild
1
CVE-2026-118306 Published Oct 27, 2026Hype score
84
critical 9.6
Google ChromeChromiumCVE-2026-118306 is a memory corruption vulnerability residing in the FileSystem component of Google Chrome. The flaw affects Google Chrome versions prior to 156.0.8078.73. It is triggered when a user interacts with a specially crafted HTML page, allowing a remote attacker to exploit the underlying memory corruption. If successfully exploited, the vulnerability allows a remote attacker to potentially execute arbitrary code outside of the browser's sandbox environment. The exploit can be initiated over a network without requiring any special privileges, though it does depend on user interaction to be executed. Google has addressed this issue in the 156.0.8078.73 update.
2
CVE-2026-118331 Published Oct 27, 2026Hype score
84
high 8.8
Google ChromeChromiumCVE-2026-118331 is a vulnerability affecting Google Chrome and other Chromium-based browsers, such as Microsoft Edge, prior to version 156.0.8078.73. The issue stems from improper input validation within the browser's FileAPI component. A remote attacker could exploit this flaw by convincing a user to visit a specially crafted HTML page, potentially allowing the attacker to execute arbitrary code within the browser's sandboxed environment. The vulnerability was discovered and reported by Anthropic researcher Xinyang Ge, who utilized the Claude AI model to assist in identifying the flaw. Google addressed the issue in late October 2026 with the release of Chrome version 156.0.8078.73/.74 for Windows and macOS, and 156.0.8078.73 for Linux. Users and administrators are advised to update their browsers to the latest version to mitigate the risk of exploitation.
3
CVE-2026-118348 Published Oct 27, 2026Hype score
84
high 8.8
Google ChromeChromiumSkiaCVE-2026-118348 is a security vulnerability stemming from improper input validation within Skia, a 2D graphics library utilized by Chromium-based web browsers. The flaw affects Google Chrome versions prior to 156.0.8078.73, as well as other browsers built on the Chromium engine, such as Microsoft Edge. The vulnerability allows a remote attacker to potentially execute arbitrary code inside the browser's sandbox. To exploit this flaw, an attacker would typically need to lure a user into visiting a specially crafted HTML page. To mitigate the risk, users are advised to update their browsers to version 156.0.8078.73 or later.
Known exploited
Sourced from CISA's Known Exploited Vulnerability (KEV) catalog.
- CVE-2026-119977 Published Oct 31, 2026
high 8.1
Exploit known
WordPress Core is vulnerable to Remote Code Execution in versions 4.7 through 7.1.3. This is due to predictable, web-accessible staging paths used during full-package core upgrades. This makes it possible for unauthenticated attackers to execute code on the server during the upgrade window.
- CVE-2026-111357 Published Oct 15, 2026
high 7.0
Exploit known
Ivanti Connect SecureCVE-2026-111357 is a privilege escalation vulnerability affecting Ivanti Connect Secure VPN appliances. The flaw stems from the system mishandling how the privileged `dsinvoked` broker trusts configuration data stored in the `DSCache`. By manipulating this trust—specifically by temporarily modifying library code in memory and altering a maintenance task in the configuration store—an attacker with local authenticated access can execute arbitrary code with root-level privileges. Discovered by cybersecurity firm Volexity, this vulnerability was actively exploited in the wild in October 2026 by a threat actor tracked as UTA0576. The attacker chained CVE-2026-111357 with an authentication bypass (CVE-2026-104935) and a predictable-filename weakness (CVE-2026-118527) to achieve unauthenticated root access on fully patched appliances, which they used to harvest Active Directory credentials and sensitive metadata. In response, Ivanti released security patches on October 29, 2026, and the Cybersecurity and Infrastructure Security Agency (CISA) added the vulnerability to its Known Exploited Vulnerabilities (KEV) catalog.
- CVE-2026-97229 Published Oct 13, 2026
Hype score
14
critical 10.0
Exploit known
GitLabGitLab CEGitLab EECVE-2026-97229 is an integer overflow vulnerability (CWE-190) located in the CI/CD Regular Expression Compiler of GitLab Community Edition (CE) and Enterprise Edition (EE). The flaw stems from insufficient validation of regular expressions used within project pipeline configurations. Under certain conditions, an unauthenticated remote attacker can exploit this vulnerability by supplying a specially crafted regular expression in a CI/CD configuration file (such as `.gitlab-ci.yml`), which can lead to arbitrary code execution on the affected GitLab server. The vulnerability affects self-managed GitLab versions 19.1 through 19.2.7, 19.3 through 19.3.3, and 19.4 through 19.4.1. Security researchers note that exploitation typically requires the ability to commit a configuration file to a repository. However, this constraint is bypassed on instances where self-registration and project creation are enabled for new users. GitLab has addressed the issue in versions 19.4.2, 19.3.4, and 19.2.8, and there have been no confirmed reports of active exploitation in the wild.
Insights
See moreOur Security Team's most recent CVE analysis
- Link to CVE page
CVE-2026-118331
high 8.8
Intruder Insights
Updated Nov 3, 2026
- Link to CVE page
CVE-2026-118348
high 8.8
Intruder Insights
Updated Nov 3, 2026
Chrome uses Skia to render graphics, and a crafted web page can abuse this input validation flaw to run code inside the browser sandbox. For most users the sandbox limits the impact, but automated browsers running without it, such as Playwright by default, are exposed to code execution on the host. No exploitation has been reported; update Chrome to 156.0.8078.73 or later, along with any other browser or app that bundles Chromium.
- Link to CVE page
CVE-2026-118344
high 8.8
Intruder Insights
Updated Nov 3, 2026
A malicious web page can exploit this use-after-free in Chrome's Layout engine to run code, but only inside the browser sandbox, so on its own it doesn't give an attacker access to the user's machine. The risk is higher for automated browsers that run without the sandbox, such as Playwright by default, where the same exploit runs directly on the host. No exploitation has been reported; update Chrome to 156.0.8078.73 or later, along with other Chromium-based browsers and Electron apps.